Jump to content
Dj's United

Denon Hd2500 V1300 Out Now


Recommended Posts

Hi all,

 

Just been on the Denon website and the latest update (v1300) for the HD2500 is there to download, I'll not put any more cos I'm sure Gary will be along soon to fill in the details

 

Jase

Link to post
Share on other sites
>

Yeah - I can add tracks to my hotlist and delete tracks from my hotlist!!!!!

 

Just one point - what's a hotlist?? And how do I use one??

DJ Dale King

 

When you see light at the end of the tunnel, beware. It's probably someone with a torch, bringing you more hassle

Link to post
Share on other sites

Well, not Gary, but Silvio !

 

 

 

:cense:NEW DN-HD2500 SOFTWARE SYS 1300:cense: (June 2008)

 

The most versatile media player and controller just got better, again.

 

 

_________________________________________________________________

 

 

Improvements:

  • -Added: Windows Vista support in MIDI mode

-Added: support for new iPod Classic & Nano (gen 6)

-Added: the ability to go back UP the search list from the Title level

-Added: Album sorting by Track ID3 tag

-Added: Folder searching by Player & Keyboard

-Added: “Hot List” Function by player and keyboard (aka, waitlist/crate)

-Added: more Keyboard functions

-Added: USB Format tool, we can now format NTFS drives to FAT32

-Improved other minor bugs listed with the firmware download

More info here:

 

http://denondj.com/plugin.asp?prod=DN-HD25...mp;x=25&y=5

 

The DN-HD2500 is currently supported by these DJ applications when used as a MIDI controller:

 

-Serato Scratch LIVE (1.8.1)

-PCDJ Reflex

-PCDJ DEX

-OTS AV

 

http://denondj.com/dnhd2500/HD2500_LineDrawing_sm.jpg

 

Link to post
Share on other sites

I'm a little confused with the new hotlist feature. The instructions state that the right arrow adds a track and the left arrow removes a track, so I set up the left side of the player with normal searching and the right side with the hotlist. As I selected a track on the left side and pressed the right arrow, it said 'added to hotlist' and it immediately appeared in the hotlist window. When I pressed the left arrow though, nothing happened. When I moved to the hotlist window and selected a track and pressed the left arrow, it said 'omitted from hotlist' and a tick appeared to the left of the track, but it was still there. I tried coming out and going back into the hotlist but it was still there. The only way I found to clear the 'ticked' songs was to turn the unit off and then back on, so.........................what am I doing wrong???

Link to post
Share on other sites

Ok...back from the US now, and even happier to help than ever.

 

 

 

What's a hot list? Well, back in Ye Olde days of DJing with vinyl, or even the newer days of DJing with CDs, if you were flicking through your music flightcases of albums for a track which you wanted, you might have flicked through an album or track which suddenly grabbed your brain and made you think "Hmm, that'll go down really well with tonights crowd,but not yet...I might play it later..." and low and behold, you'd pull the chosen piece of vinyl/CD jewel case halfway out of the flightcase and leave it tilted at a jaunty 45 degrees, so that it wouldn't (easily) slide back down. Hot List is just like that.

 

 

 

On the DN-HD2500, you can search by all the usual methods....eg: display instantly all the tracks by a certain artist/group....or display all song titles with a specific word/selection of text in them, or all the tracks from such'n'such year...you can also use search by a range of BPM's eg: A user-selectable number of BPM higher/lower than the BPM which you're searching for. You can even use Two-Step search to show only those tracks which match both of two criteria which you search for - eg: Whitney Houston tracks where the BPM is around 128, or tracks from 1985 with the word/text "danc" in the title etc.

 

 

 

At any time, during any search, (which all provide -instant- results on the DN-HD2500), you can either select a track instantly to play next on either deck, or now you can add any track in the on-screen search results to the Hot List.

 

 

 

Hot List is a playlist which can hold upto 99 tracks which you can add to even while the other side of the 2500 is playing a track. These tracks can be songs which people have requested at the "wrong" time - eg: "red red wine", just when you've got everyone dancing to fast tracks... or tracks which you've thought of playing "later". You can call up the Hot List on either side of the 2500 and add, or cue up any of the tracks which you've placed within it. When you cue up/play a track in the Hot List, on either side of the 2500, a tick/check mark appears by the side of that track to show that it's no longer waiting to be played.

 

 

 

Also, if that blonde girl with the massive pair of...eyes, who requested that you play several tracks for her, is seen leaving just after scoffing the buffet, you can use the Omit from Playlist (left hand arrow on a USB keyboard) function, to add a tick/check mark to all her tracks so that you don't still play them. A feature in the Utility menu allows the removal of all tracks in the Hotlist which have the tick/check mark against them.

 

 

 

 

 

 

Link to post
Share on other sites

Can you explain how to remove them and also if you reach the 99 limit what happens, does it remove the ticked songs automatically or does it just say it's full? Thanks

Link to post
Share on other sites

I've not taken the Hotlist up to 99 tracks at a gig yet, although used Hotlist at about 6 gigs so far. I've just tried it, and got the message "Hotlist is Full" when I tried to add an extra track to a Hotlist of 99 tracks (roughly 6.5 hours of music already).

 

 

 

Removing tracks in the Hotlist which have been marked with a tick/checkmark, eg: ones which you've already played, or used the "Omit from playlist" option on, just go into the Utility Menu, via the Utility button on the 2500, and choose the Edit Hotlist menu option.

 

 

Link to post
Share on other sites

Can someone please tell me how to remove version 1300 and go back to 1200, because for having the hotlist feature with all the other changes that have come along, I'll just stick to version 1200 and a pen and paper.

Edited by bigMCben
Link to post
Share on other sites

What do you mean Big McBen?

 

I am yet to install V1300 on mine, what makes the upgrade so bad?

 

Surely if you (or I) dont like the hotlist feature, you just dont use it??

There's loads of features I dont use all ready....

DJ Dale King

 

When you see light at the end of the tunnel, beware. It's probably someone with a torch, bringing you more hassle

Link to post
Share on other sites

The issues I've found with the 1300 software are

 

Doing search by album, unit locks up and song that is playing stops then starts playing slowly (like brake in reverse). This continues in a loop and I had to switch off and back on. Make sure you have your backup music ready to play if you're doing an album search.

 

If you used the controls on the denon, the keyboard automatically switched to that side, now it doesn't, so issue below means that occassionally you press enter thinking you're on one side of the unit when in fact you're still on the side that's playing, so pressing enter causes the song currently playing to stop and reload. (happened four times friday night)

 

Hotlist. For some reason the playlock occassionally disengages, which can cause problems. SEE ABOVE

 

When searching say an artist, I might return 3 entries for Status Quo (I know I should sort out my tags but that's a seperate issue). I would select the first one and see if the song I wanted was there. if not, press back and then select the next status quo and check and so on. Now when you press back, you go right back to the start and have to type in status quo and enter and try and remember which ones you've already checked and so on.

 

If you are using the hotlist feature, as soon as you select a song to play, a tick appears which means it won't appear the next time you use the hotlist. Now a couple of times I've selected a song to play only to change my mind, but I can't remove the tick, so the next time I look it appears that it's been played and if I can't remember I've changed my mind and not played it I'm stuffed.

 

I appreciate that the software is made for a worldwide market and these changes, whether accidental or deliberate, are not to my liking, so I'll just go back to v1200 at the moment and if v1400 addresses these issues then great, if not, I'll just stick to v1200. As the say if it ain't broke, don't fix it.

Link to post
Share on other sites
The issues I've found with the 1300 software are

 

Doing search by album, unit locks up and song that is playing stops then starts playing slowly (like brake in reverse).

 

 

 

 

 

I'll be sending you a PM hopefully by the end of tonight (GMT) with some additional info, but let me clarify a couple of things first.

 

 

 

The "Stops playing, then sloooooowly starts" is not the firmware, or the DN-HD2500 - it's the speed of the external device - eg: disk drive, disk drive firmware, hub, or lead. I've seen this several times and seen it replicated deliberately where a nice fast (USB 2.0) Powered, external drive, with a good USB2.0 lead runnig through a powered USB 2.0 hub, is working fine. Everything is switched off, and the USB2.0 hub is switched with an unpowered, and USB1 hub...after a while, the drives cache fills up and when more demand for data is made, the drive cant send the data through the hub at the desired speeds. Not a problem if all you're waiting for is a Word document, or an Excel Spreadsheet, it just takes a bit longer to load - but obviously when its music delivery, the bottleneck is very noticable.

 

 

 

I've been using the V1300 firmware on my own drives and hubs at home and at gigs for several weeks now, and no "slooooow" problems.

 

 

 

The Playlock, Keyboard switching is being looked into, following your mention of it. (yes, already being looked into even though its a weekend :lol: - on both sides of The Atlantic - directly after my gig last night in fact)

 

 

 

You mention "If you are using the hotlist feature, as soon as you select a song to play, a tick appears which means it won't appear the next time you use the hotlist. "

 

 

 

The ticked items on a hotlist do not disappear when you go back into the hotlist - indeed, they're not supposed to. If you play a track in your hotlist, say..."Drifters: Under the boardwalk" whether it's just into the headphones, or out to the audience - the "played" tick will appear beside the track in the hotlist to show "played". There is no way of removing the played tick from a played track - although, if you're seriously forgetful - there's nothing to stop you adding "Drifters: Under the boardwalk" to the hotlist again.

 

 

 

PM you later.

 

 

Link to post
Share on other sites

Hi Gary

 

Just to expand your going slooooooooow point above... I haven't had it with the new version, but I had it with V1200. My point is that it did it with the internal drive - NOT an external drive, so I would've assumed that the internal drive would've been quick enough?

 

I was hoping that the V1300 would fix this, as it is a REAL scarey time when it happens. Sometimes a quick pause and play fixes it, but sometimes it doesnt..

 

Now my problem with the V1300 is when I press PLAYLIST and +, the system just puts me into playlist mode - it doesn't add anything to the hotlist..

 

Any ideas?

Link to post
Share on other sites
Hi Gary

Just to expand your going slooooooooow point above... I haven't had it with the new version,

 

 

 

Good to hear. You're correct in believing that the internal drive is fast enough for all sorts of data transfer at suitable speeds to avoid the sort of bottlenecks which we're talking of above. The only thing which I'm aware of which would have caused slow playback from internal HDD is database issues - which would have been cleared when the 2500 created the new database as part of the firmware upgrade procedure.

 

 

 

 

 

Hi Gary

Now my problem with the V1300 is when I press PLAYLIST and +, the system just puts me into playlist mode - it doesn't add anything to the hotlist..

 

Any ideas?

 

 

 

Ideas? Yes!

 

 

 

Try this (and sorry if this is what you've tried already.)

 

 

 

* Search for any song, any way you like, eg: by artist, title, bpm, year...any...

 

 

 

* when the song is highlighted on-screen (the 2500 screen), hold down the "Playlist" Button (as if it were a SHIFT key on a PC) and with that button still held down, press the Pitch bend "+" key, which is just below the Playlist button.

 

 

 

alternatively...

 

 

 

* Have a USB keyboard connected to the 2500

 

 

 

* Search for any song, any way you like, eg: by artist, title, bpm, year...any...

 

 

 

* when the song is highlighted on-screen (the 2500 screen), press the right hand arrow on the keyboard.

 

 

 

 

 

Again sorry if these are exactly what you've tried already.

 

 

 

Let me know how you get on.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Link to post
Share on other sites

Hi Gary

 

I haven't tried it with a keyboard yet, hoping that it would work with the unit itself - I ain't had a gig yet back in Blighty - the first is this weekend.

 

When I do what you suggest above with the 2500 itself, the second I press PLAYLIST, it immediately goes into playlist mode with the playlist light lit....

 

If I press pitch + and then PLAYLIST, it does exactly the same thing - Goes straight into PLAYLIST mode.. There is no way for this not to happen and its a little depressing...

 

 

Link to post
Share on other sites

When I do what you suggest above with the 2500 itself, the second I press PLAYLIST, it immediately goes into playlist mode with the playlist light lit....

 

If I press pitch + and then PLAYLIST, it does exactly the same thing - Goes straight into PLAYLIST mode.. There is no way for this not to happen and its a little depressing...

 

My two initial thoughts are:

 

A) the firmware upgrade on your unit didnt complete.

 

B) the pitch bend + button isn't working.

 

 

For A) can you try re-loading the firmware either from internal hdd or pen drive etc. And for B), try using playlist button and + on the other side of the controller. (both buttons on the same side though...not left deck playlist button with right deck side pitch bend +) (I'm sure you wouldn't have done opposite sides buttons, but...)

 

Again, let me know how it goes

Link to post
Share on other sites
Guest EliteDJ

My two initial thoughts are:

 

A) the firmware upgrade on your unit didnt complete.

 

B) the pitch bend + button isn't working.

For A) can you try re-loading the firmware either from internal hdd or pen drive etc. And for B), try using playlist button and + on the other side of the controller. (both buttons on the same side though...not left deck playlist button with right deck side pitch bend +) (I'm sure you wouldn't have done opposite sides buttons, but...)

 

Again, let me know how it goes

 

 

I have the same problem as Tonsk, although intermittently it'll work the way it should. The firmware is installed correctly and the pitch bend + is working perfectly.

Link to post
Share on other sites

intermittently it'll work the way it should. The firmware is installed correctly and the pitch bend + is working perfectly.

 

thanks for that.

 

Are you able to define, in this context, what the intermittent-ness is? Eg: wave files vs mp3, files on internal drive vs files on an external drive...

 

 

 

intermittently it'll work the way it should. The firmware is installed correctly and the pitch bend + is working perfectly.

 

thanks for that.

 

Are you able to define, in this context, what the intermittent-ness is? Eg: wave files vs mp3, files on internal drive vs files on an external drive...

 

 

 

intermittently it'll work the way it should. The firmware is installed correctly and the pitch bend + is working perfectly.

 

thanks for that.

 

Are you able to define, in this context, what the intermittent-ness is? Eg: wave files vs mp3, files on internal drive vs files on an external drive...

 

 

Link to post
Share on other sites
Guest EliteDJ

thanks for that.

 

Are you able to define, in this context, what the intermittent-ness is? Eg: wave files vs mp3, files on internal drive vs files on an external drive...

thanks for that.

 

 

 

 

Hi Gary,

 

I've just tried a broad test on internal drive and external using a selection of different mp3s. I used each file about 10 times in total one after the other using the playlist feature on the controller. Probably 6 or 7 times out of 10 it wouldn't work as should and resulted in the problem mentioned earlier. It made no difference whether the file was on the internal drive or external. Additionally, I tried ripping a few tunes in WAV format, placing the tune on both the internal hdd and external....and the same thing happens. The intermittentness (sp?) really is random with no set pattern.

 

Overall it's not really a problem for me as I've been using the keyboard up till now. It's just strange to say the least.

Edited by EliteDJ
Link to post
Share on other sites

just installed the new firmware earlier before reading this ??? getting worried lol as it dosent seem to be working for people on here ! but as for the slowing problem and slowly correcting itself i have been having that problem since v1200up and am hopeing that 1300 was gonna sort it

 

as for the keyboard auto detecting im guessing someone just forgot about that feature when they were putting the firmware together lol but im guessing there will be a second release coming soon ???

 

as for the slow problem i will post on here if it is sorted as i think it might just have been the fact that i didnt re-create the databases after the last firmware upgrade cause it never done it when i first got the machine started only after the firmware upgrade so currently re-creating all databases internal & external now and will see how it goes this weekend

Link to post
Share on other sites

 

Probably 6 or 7 times out of 10 it wouldn't work as should and resulted in the problem mentioned earlier.

 

 

 

Good testing. Was all the testing done on just one side of the deck? Eg: Just using the left side controls.

 

 

 

Absolutely no one else, worldwide, has reported on a forum, or to Denon US or UK any intermittant Hot list adding. I'm suspecting the "Pitch bend +" button at the moment... , hence wondering if you'd been trying loading the hot list from both left and right sides of the unit (the idea being that having 2 pitch bend buttons "go", is less likely).

 

 

 

The sloooooow track playback if occuring on the internal drive is extremely uncommon, and I would suspect the one-off integrity of the internal drive if one started doing that - together with the overal intergrity of the files (VBR for example). Sloooow playback from external drives is most commonly down to the external drive not being able to pass data out, fast enough - usually due to the drive itself having "feature software" built-in (like one-button-press backup type features), or the enternal drive or hub only being USB powered as opposed to being fully powered from a mains power supply adaptor - or the hub being USB 1.0/1.1 rather than 2.0.

 

 

 

 

 

 

Link to post
Share on other sites
Guest EliteDJ

Good testing. Was all the testing done on just one side of the deck? Eg: Just using the left side controls.

 

 

 

Absolutely no one else, worldwide, has reported on a forum, or to Denon US or UK any intermittant Hot list adding. I'm suspecting the "Pitch bend +" button at the moment... , hence wondering if you'd been trying loading the hot list from both left and right sides of the unit (the idea being that having 2 pitch bend buttons "go", is less likely).

 

 

 

 

Hi Gary,

 

I've only tried it on the right had side so far. I'll give it a good test on both sides at tomorrows gig.

Link to post
Share on other sites
Guest EliteDJ

I never got round to testing it yesterday as I've had SERIOUS problems with music manager messing up my tags when updating database (a problem that a few people are having going by the denon forums)...but that's a whole new topic altogether. I'm starting to wish I'd bought a Numark.

Link to post
Share on other sites

I used V1300 over the weekend and had a nightmare with it..

 

Plugged my Maxtor directly into the 2500, not using a keyboard and when pressing the + button linked to the external drive it once again sped up, only fixable by resetting.

 

Plus whenever I tried opening a playlist, it firstly took its time to do so and then the characters kept disappearing until I went up a level and reselected.

 

The system IS upgraded - I did update it again to make sure and I still can't add files through PLAYLIST and + (didn't have the keyboard on).

 

HELP please.... I love the 2500 but it seems like V1300 didn't work....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...