Jump to content



djbzentertainment

Member Since 22 Sep 2003
Offline Last Active Jul 30 2013 09:51 PM
-----

Topics I've Started

Dead Amp!

08 August 2010 - 03:53 PM

Does this sound (A) Terminal
(B) Expensive
© Stop messing about and buy a new one?

Warrior IS600 amplifier, approx 6 years old, bought new initially. When power switch is turned on, there is a click from the amp, the fan keeps running but there is no sound output. (power on indicator light bulb blew ages ago, so there are no visual clues.)


Is it repairable? Is it worth it at that age?

The only reason i ask is that if anyone has experienced a problem like this and it turned out to be nothing more than a blown fuse....................


Thanks in advance for your comments.


Bob

Sorry for the 3 posts, my laptop is misbehaving somewhat!

Decisions Decisions.....

23 June 2010 - 07:04 AM

Ok, what would you do here, i have a KAM KXR1500 amp, a Warrior IS600 amp, a pair of 300 watt AC Euro Mid Range 8ohm speakers and a pair of Behringer 300 watt 4ohm Subs. The KXR1500 runs at 750 watt per channel into 4 OHM and 450watt per channel into 8 ohms. The IS600 amp runs at 300 watts per channel at 4 ohms and 180 watts per channel at 8 ohms. I have always used the warrior amp with the AC Euros and at some gigs have been running the Warrior Amp into clip, so, no headroom left at all. The subs do not give a punchy bass they give a proper subwoofer rumble, i find that the punchy bass tends to come from the AC Euros. Should i use the KXR1500 for the AC Euros and the Warrior for the subs? I may be wrong but i think that may give a better sound and provide more power where its needed (i.e the mid range speakers) or have i got this all totally wrong as usual???!!!


Many thanks in advance for your comments.


Bob

Big Night Tonight!

21 May 2010 - 08:01 AM

Hello all,

Am doing a gig tonight for a cancer charity in Leeds, its been advertised as a non stop disco party night, its a total sell out and i have been at the venue for a couple of hours each night setting up the lighting rigs etc. Have decided to use every effects light i own at this gig so have been refurbishing old lights this week i have not used for a few months. I hope to god it all goes well!!!

Will post photos and stuff soon!



Bob

Acme Rover Barrel Scanner

10 May 2010 - 07:03 AM

Good morning all!

I have a pair of Acme Rover Barrel Scanners and one of then has developed a fault. I noticed during a gig on Saturday night that the colour was not changing on one of them. I had the unit in bits last night (well, i say in bits, i took the front panel off so i could see the gobos turning). The colour gobo is not turning, but the gobo can be turned by hand and it is not stiff or catching anything. Now, what i would like to know is how can i test to see if its the stepper motor or a faulty connection or something like? Second question would be, anybody know where to buy spare parts for these lights?



Many thanks in advance,



Bob



Speaker Set Up And Advice

25 April 2010 - 08:43 PM

I may be about to make myself look pretty stupid asking a question like this but here goes. I have a pair of ac euro mid range speakers running off a warrior 600 watt amp. Superb, no problem. I also have a pair of 300 watt behringer bass bins running off a kam kxr1500 amp. The speakers are 4 ohm hence the big amp. What I cannot understand is that the bass bins do not seem to do much. Now here's the possibly stupid bit. The 600 watt amp is turned right up and I control the volume from the mixer. The big amp is turned up to just over half, because I do not want to blow the speakers up when the volume goes up later on in the night. Should I turn it right up? Do I need another bit of equipment other than 4 soles two amps and a mixer? Any advice would be gratefully recieved.


Bob